SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 06-06-2011, 05:07 PM   #1
walterjonesw
Junior Member
walterjonesw is on a distinguished road
 
Join Date: Jun 2011
Posts: 11

2003 ION-3 Sedan
Default idle problem

have a problem with my 2003 saturn ion it starts to idle high and tries to stall out when coming to a complete stop, it will stumble then idle high, it doesnt do it all the time and when it does i just turn off car wait a sec then we start it and no more problem a while went to autozone and tried getting more info on the efi system guy told that i needed to check and clean the throttle air bypass switch, i checked the book to see where the switch was as at but only i could find was the idle air control switch the picture in the book matches but it tells me not soak it cleaner, so before i go trying something that may be damaging, does anybody have any opinions on what may be causing the problem and a safer way of cleaning carbon buildup off the sensor

REWARD EXCELLENCE!

Add to walterjonesw's Reputation
Rate the quality of this post and help walterjonesw reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
walterjonesw is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 06-06-2011, 05:50 PM   #2
lgodave
Senior Member
lgodave will become famous soon enough
 
Join Date: Apr 2004
Location: WI
Posts: 1,648
 

2003 ION-3 Sedan
Default Re: idle problem

If you are talking about cleaning your throttle body... I'd certainly recommend it. It's fairly straight forward on my 2003 ION. Did mine just a few months ago... along with changing the spark plugs and cleaning the filter and various sensors.


As others may suggest pull the Throttle Body off the vehicle and use a throttle body cleaner and MAF Sensor Cleaner (no MAF sensor on the 2003 but it's safe for use on the electronics that are there). The sensors on the Throttle Body are easily removed and cleaned.

REWARD EXCELLENCE!

Add to lgodave's Reputation
Rate the quality of this post and help lgodave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lgodave is offline   Reply With Quote
Old 06-06-2011, 06:12 PM   #3
Zosozeppelin
Advanced Member
Zosozeppelin is on a distinguished road
 
Zosozeppelin's Avatar
 
Join Date: Dec 2010
Location: New Orleans, Louisiana
Posts: 649

2006 ION-3 Quad Coupe
Default Re: idle problem

I just brought mine to Pep Boys and had the whole fuel system taken care of. Rode super smooth after that.

...
Elizabeth

'06 Level 3 Quad Coupe. 116K as of 1-8-14.

REWARD EXCELLENCE!

Add to Zosozeppelin's Reputation
Rate the quality of this post and help Zosozeppelin reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Zosozeppelin is offline   Reply With Quote
Old 06-06-2011, 06:29 PM   #4
walterjonesw
Junior Member
walterjonesw is on a distinguished road
 
Join Date: Jun 2011
Posts: 11

2003 ION-3 Sedan
Default Re: idle problem

i will give the cleaning throttle body a try, need to change spark plugs too, tried taking to pep boys but since problem stops when car turn on and off pep boys said they didn't know what problem could be and they would have to do a full system diagnoses but when i was having problems with the car overheating i had a complete diagnose done (very expensive), and only problem they found was in the electrical there were loose wires on the computer they had to fix but everything thing else checked out

REWARD EXCELLENCE!

Add to walterjonesw's Reputation
Rate the quality of this post and help walterjonesw reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
walterjonesw is offline   Reply With Quote
Old 06-06-2011, 07:32 PM   #5
snakes
Member
snakes will become famous soon enoughsnakes will become famous soon enough
 
snakes's Avatar
 
Join Date: Mar 2008
Location: NY
Posts: 419

2005 ION-1 Sedan
Default Re: idle problem

definately give the throttle body a try and clean your MAF sensor. it could be oxygen being cut off. I had a similar situation ad had to replace my throttle, however it would only happen to me when I put it in park. if that doesnt work
I hate to say this but maybe in this situation you should bring it to a remaining saturn service dept or chevy or any GM dealer. The guys over at pepboys prob arent as knowledgible. could it maybe be the MAF?

REWARD EXCELLENCE!

Add to snakes's Reputation
Rate the quality of this post and help snakes reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
snakes is offline   Reply With Quote
Old 06-06-2011, 07:39 PM   #6
Zosozeppelin
Advanced Member
Zosozeppelin is on a distinguished road
 
Zosozeppelin's Avatar
 
Join Date: Dec 2010
Location: New Orleans, Louisiana
Posts: 649

2006 ION-3 Quad Coupe
Default Re: idle problem

Quote:
Originally Posted by snakes View Post
definately give the throttle body a try and clean your MAF sensor. it could be oxygen being cut off. I had a similar situation ad had to replace my throttle, however it would only happen to me when I put it in park. if that doesnt work
I hate to say this but maybe in this situation you should bring it to a remaining saturn service dept or chevy or any GM dealer. The guys over at pepboys prob arent as knowledgible. could it maybe be the MAF?
Very true. Find a Saturn Authorized Service Provider and have them check it out. I have my diagnostics done at GM dealerships.

...
Elizabeth

'06 Level 3 Quad Coupe. 116K as of 1-8-14.

REWARD EXCELLENCE!

Add to Zosozeppelin's Reputation
Rate the quality of this post and help Zosozeppelin reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Zosozeppelin is offline   Reply With Quote
Old 06-06-2011, 10:36 PM   #7
2006 ion2
Master Member
2006 ion2 will become famous soon enough2006 ion2 will become famous soon enough
 
Join Date: Jun 2007
Location: Da U.P, EH!
Posts: 8,121
 

2007 ION-2 Sedan
Default Re: idle problem

Quote:
Originally Posted by snakes View Post
definately give the throttle body a try and clean your MAF sensor. it could be oxygen being cut off. I had a similar situation ad had to replace my throttle, however it would only happen to me when I put it in park. if that doesnt work
I hate to say this but maybe in this situation you should bring it to a remaining saturn service dept or chevy or any GM dealer. The guys over at pepboys prob arent as knowledgible. could it maybe be the MAF?
you<reading. no maf in an 03-04.

clean the TB and the 2 sensors (IAC and TPS) in it, along with the MAP sensor. if that fails, you most likely have an air leak between the throttlebody and head (vacuum leak). spark plugs are good to 100K miles if they're the OEM iridium plugs (my 04 malibu had them, not sure when ions started shipping with them).

...
2007 Saturn Ion 2
2003 Chevrolet venture lt

trifecta dealer for the U.P. and WI. There is no two door ion. Proudly driving one of the last saturns produced before gm killed the brand.

REWARD EXCELLENCE!

Add to 2006 ion2's Reputation
Rate the quality of this post and help 2006 ion2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
2006 ion2 is offline   Reply With Quote
Old 06-07-2011, 01:09 PM   #8
lgodave
Senior Member
lgodave will become famous soon enough
 
Join Date: Apr 2004
Location: WI
Posts: 1,648
 

2003 ION-3 Sedan
Default Re: idle problem

Quote:
Originally Posted by 2006 ion2 View Post
you<reading. no maf in an 03-04.

clean the TB and the 2 sensors (IAC and TPS) in it, along with the MAP sensor. if that fails, you most likely have an air leak between the throttlebody and head (vacuum leak). spark plugs are good to 100K miles if they're the OEM iridium plugs (my 04 malibu had them, not sure when ions started shipping with them).
+1

My Dec. 2002 manufactured 2003 ION-3 came with ACDelco Platinum plugs. There are several sources that suggest Platinums would have a practical service range less then Iridium plugs that should last 100K. Mine seemed OK around 90K (course I haven't seen what they should look like new) when I replaced them with Iridium plugs.

My TB hadn't been cleaned till I swapped out the plugs. Seemed rather straight forward. My particular issues were removing arm holding the Throttle Cable and removing the Cable from the TB (since it had kind of settled/oxidized in place) but with a little patience (and care not to drop or damage anything) it went easy enough.

REWARD EXCELLENCE!

Add to lgodave's Reputation
Rate the quality of this post and help lgodave reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lgodave is offline   Reply With Quote
Old 06-08-2011, 12:52 AM   #9
walterjonesw
Junior Member
walterjonesw is on a distinguished road
 
Join Date: Jun 2011
Posts: 11

2003 ION-3 Sedan
Default Re: idle problem

thank you all am diffently going to try cleaning the tb and also the info on the spark plugs i will try the iridium plugs didnt know they last longer,

REWARD EXCELLENCE!

Add to walterjonesw's Reputation
Rate the quality of this post and help walterjonesw reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
walterjonesw is offline   Reply With Quote
Old 07-01-2011, 04:06 PM   #10
R01970
New Member
R01970 is on a distinguished road
 
Join Date: Jul 2011
Posts: 2
Default Re: idle problem

I also own a 03 Ion 2 and I read a few days ago while I was searching the recalls for this model and somehow when they were first produced they were having the Idle problem driving them brand new right off the lots. I am having problems myself w the tranny. I am going to try adding some DEX CVT fluid to see if it will fix the problem a bit. I am not very happy into looking to so some work into it at this time thou. Also read on and you will find a problem with the bumper separating on the front right side which mine is starting to happen which actually is a definite recall on this model. Hope any of this info helped.

REWARD EXCELLENCE!

Add to R01970's Reputation
Rate the quality of this post and help R01970 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
R01970 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle problem/idle problem sc2dohc94 S-Series Tech 8 08-10-2008 11:31 AM
Low Idle...IAC Problem? vd_2kil_cm1 S-Series Tech 1 05-09-2008 08:42 PM
idle problem Carlyle S-Series Tech 15 03-31-2007 11:43 AM
98 Sl2 Hi Idle Problem LEW100 S-Series Tech 1 03-21-2005 10:48 PM
Idle problem with AC on........ Mark92SC2 S-Series Tech 15 09-02-2003 09:37 PM


All times are GMT -5. The time now is 12:44 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.