SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-07-2009, 02:27 PM   #1
orionkc
New Member
orionkc is on a distinguished road
 
Join Date: Jan 2009
Location: Watertown, MN
Posts: 5

1999 SL2
Dizzy 99 sl2 rough idle question

Heres what is going on. I have a 99 saturn sl2 dual overhead and its running rough. newyears eve was driving out of town when I noticed it start to run wierd while on the highway (did this before and went away) Came to a stop light and thought it was going to stall it was running so bad. When I got to where we were going I let it sit over night thinking this would solve something. started it and it was running like a harley! engine shaking badly. Checked out the diagnostic and called my mechanic and said it was likely the egr! I have since cleaned the egr as per the topic thread here and it ran a lot better but still a bit funky. do you think I should replace egr? when I ran the engine with the egr off it sounded weird like a knock was going on but when egr is on I cant heard any knock. Seems like its running fine but rough. exhaust doesnt sound smooth. could it just be the plugs and wires?

Could it be the plugs and wires? Also I have noticed a gas/coolant smell.

Any thoughts before I have to take to a mechanic and spend tons of money?

Thanks

REWARD EXCELLENCE!

Add to orionkc's Reputation
Rate the quality of this post and help orionkc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
orionkc is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-07-2009, 02:33 PM   #2
OnDaGround
Master Member
OnDaGround has a spectacular aura aboutOnDaGround has a spectacular aura about
 
OnDaGround's Avatar
 
Join Date: Jun 2008
Location: Get off my lawn!!
Posts: 4,842
 

1993 SC2
Default Re: 99 sl2 rough idle question

Quote:
Originally Posted by orionkc View Post
Seems like its running fine but rough. exhaust doesnt sound smooth. could it just be the plugs and wires?

Could it be the plugs and wires? Also I have noticed a gas/coolant smell.

Any thoughts before I have to take to a mechanic and spend tons of money?

Thanks
Wires and plugs... definetly. If they have not been replaced in a while I would do so. Check the wires for any signs of corrosion. (metal flakes... falling apart and what not... It will probably have some on the coil pack towers.) Plugs are easy to tell if they are fouled. If its really that bad, you may have a cracked plug. Replace these with NGK copper plugs.

As far as the exhaust check the muffler strap as normally that has a tendancy to rust and then the rust eats a hole through the muffler. (on the top of the muffler more than likely) That would be the first place I would check. Second is the flex-pipe for the cat... make sure the weaving is not torn or busted as that is possible and likely. Third, check the flanges for the cat to the muffler and to the flex pipe....

Have fun. Check and make sure your ect is changed and the connector is not corroded.

...
Saturnless...

REWARD EXCELLENCE!

Add to OnDaGround's Reputation
Rate the quality of this post and help OnDaGround reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OnDaGround is offline   Reply With Quote
Old 01-07-2009, 02:38 PM   #3
OnDaGround
Master Member
OnDaGround has a spectacular aura aboutOnDaGround has a spectacular aura about
 
OnDaGround's Avatar
 
Join Date: Jun 2008
Location: Get off my lawn!!
Posts: 4,842
 

1993 SC2
Default Re: 99 sl2 rough idle question

ECT= Engine Coolant Temperature Sensor... these little guys can cause a world of trouble and make misdiagnosis very easy to occur. It is a cheap simple repair. Take care of this, as it will save you alot of money and time. It can cause an SES light... or even a no-start.

96-up saturn DOHC coolent temp sensor location
http://www.youtube.com/watch?v=pUwCTJRqnAk

Engine Coolant Temperature Sensor Connector Replacement
http://www.youtube.com/watch?v=yQx84-93WkE

Engine Coolant Temperature Sensor R&R Saturn S-series
http://www.youtube.com/watch?v=JC0U53w_Htk

* If you get an aftermarket sensor, a roll of teflon tape will be needed to help it seal properly (this is in the video) other wise it will leak and the leaking causes it to get on the connector which is where the corrosion on the connector occurs. It is only necessary to replace the connector if it is corroded or shows signs of damage.*

...
Saturnless...

REWARD EXCELLENCE!

Add to OnDaGround's Reputation
Rate the quality of this post and help OnDaGround reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OnDaGround is offline   Reply With Quote
Old 01-07-2009, 03:43 PM   #4
DonP
Master Member
DonP will become famous soon enoughDonP will become famous soon enough
 
Join Date: Jun 2006
Location: VA
Posts: 3,580
 

1995 SL2
Default Re: 99 sl2 rough idle question

As noted above, check the ECTS and connector - after you ensure they are good, you can move on to other diagnosis in a meaningful way. A failed ECTS could result in the coolant and gas smell.

There are several current active threads on finding common coolant leaks (if it is not leaking around a failed ECTS).

REWARD EXCELLENCE!

Add to DonP's Reputation
Rate the quality of this post and help DonP reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
DonP is offline   Reply With Quote
Old 01-11-2009, 06:00 PM   #5
orionkc
New Member
orionkc is on a distinguished road
 
Join Date: Jan 2009
Location: Watertown, MN
Posts: 5

1999 SL2
Dizzy Re: 99 sl2 rough idle question

Ok so heres what I did. Took off the egr and cleaned. Next replaced the ects, changed the plugs and wires. Seems to keep getting better but isnt. Still runs fairly rough!

We and had a scan and I came back #4 miss fire. went and cleaned the ignitions module and coils, rechecked the wires and checked for spark on each one plug all plugs sparked and all wires worked. put everything back together and like I said above keeps getting better each time I work on it!

monkeyed with the injector connections and started er up and seemed to get better (not fully back to normal) took it for a spin and kept getting check engine light flashing and idled at stop funny.

So whats next? clean the injectors? Also the exhaust is going out. that would make the engine runn funny as well? Not enough back pressure?

Thanks for the help so far! I am at a loss!

REWARD EXCELLENCE!

Add to orionkc's Reputation
Rate the quality of this post and help orionkc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
orionkc is offline   Reply With Quote
Old 01-11-2009, 06:02 PM   #6
orionkc
New Member
orionkc is on a distinguished road
 
Join Date: Jan 2009
Location: Watertown, MN
Posts: 5

1999 SL2
Default Re: 99 sl2 rough idle question

and yes I put in ngks!

REWARD EXCELLENCE!

Add to orionkc's Reputation
Rate the quality of this post and help orionkc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
orionkc is offline   Reply With Quote
Old 01-11-2009, 08:31 PM   #7
OldNuc
Super Member
OldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud of
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 50,553
 

1998 SC2
Default Re: 99 sl2 rough idle question

Back pressure will not make it run bad. You do have the firing order set right, per the picture on the radiator support? The #1 and #4 wire must run from the coil to the cam cover next to each other. Look at the coils, see that trace running along the side to the mounting bolt? Remove those 2 bolts, one for each coil, and clean under the bolt head.

Last but not least, run a wet and dry compression test. Harbor Freight sells a compression tester for $8.00 and that's all you need to do the test. If fiddling with the injector plugs makes it run better that could mean that a cylinder was running lean and that can burn a valve. That's why a compression test is a good idea.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 01-11-2009, 08:46 PM   #8
orionkc
New Member
orionkc is on a distinguished road
 
Join Date: Jan 2009
Location: Watertown, MN
Posts: 5

1999 SL2
Default Re: 99 sl2 rough idle question

Thanks for the responce!

#1 + #4 wires running along each other. bolts and ignition coils and module cleaned.

I will do a compression test tomorrow. Anything else?

REWARD EXCELLENCE!

Add to orionkc's Reputation
Rate the quality of this post and help orionkc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
orionkc is offline   Reply With Quote
Old 01-11-2009, 09:35 PM   #9
OldNuc
Super Member
OldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud ofOldNuc has much to be proud of
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 50,553
 

1998 SC2
Default Re: 99 sl2 rough idle question

No, Not till we know what the compression is. Next step would be playing musical injectors. Which is a PITA.

When you do the compression check compare allof the plugs to each other. Might be useful information.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
95 SL2 Rough Idle Davidalyn S-Series Tech 1 09-26-2008 03:12 PM
Rough Idle 95 SL2 jimmyz S-Series Tech 11 04-18-2007 08:40 AM
95 SL2 Rough Idle bdwagne S-Series General 3 09-14-2005 09:22 PM
96 SL2 rough idle kej53 S-Series Tech 8 08-11-2005 08:45 PM
99 SL2 rough idle problems thomp S-Series General 8 04-29-2005 10:18 AM


All times are GMT -5. The time now is 09:45 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.