SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-19-2017, 04:10 PM   #1
jswingchun
Member
jswingchun is on a distinguished road
 
jswingchun's Avatar
 
Join Date: Sep 2005
Location: Center Point, Iowa
Posts: 199
 

1992 SL2
Default Speedometer/Odometer not working

I have a 92 SL2, manual transmission.

My speedometer and odometer are not working. Speedometer is at zero, odometer is not turning. All other gauges work.

I have read quite a bit on here about this, I know that the vehicle speed sensor is often the cause of this, but my cruise control is working and if I have read correctly that should rule out the VSS.

Am I right?

Where should I start?

Thanks!!

...
92 SL2 - 280k miles

REWARD EXCELLENCE!

Add to jswingchun's Reputation
Rate the quality of this post and help jswingchun reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jswingchun is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 10-19-2017, 04:31 PM   #2
RobertGary1
Master Member
RobertGary1 is just really niceRobertGary1 is just really niceRobertGary1 is just really niceRobertGary1 is just really niceRobertGary1 is just really nice
 
Join Date: Jun 2005
Location: Sacramento
Posts: 3,754
 

1996 SC2
2006 VUE 3.5L
Default Re: Speedometer/Odometer not working

Swap the cluster with one from a junk yard.

-Robert

REWARD EXCELLENCE!

Add to RobertGary1's Reputation
Rate the quality of this post and help RobertGary1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RobertGary1 is offline   Reply With Quote
Old 10-21-2017, 01:02 PM   #3
stmcmurray76
New Member
stmcmurray76 is on a distinguished road
 
Join Date: Oct 2017
Posts: 1
Default Re: Speedometer/Odometer not working

I have interest in this topic. I need to replace the guage cluster in my 92 Saturn SL1. Sounds easy enough, but when I search for it, the cluster is different than mine. I have seen a few photos of the cluster I need, and they are from 95 and 96,but it seems not all 95 and 96. I guess I just need to go walk through the junk yard and see if I can find a match. Any idea why there is no consistency with the use of this peticular cluster?

REWARD EXCELLENCE!

Add to stmcmurray76's Reputation
Rate the quality of this post and help stmcmurray76 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
stmcmurray76 is offline   Reply With Quote
Old 10-21-2017, 03:04 PM   #4
fetchitfido
Super Member
fetchitfido has much to be proud offetchitfido has much to be proud offetchitfido has much to be proud offetchitfido has much to be proud offetchitfido has much to be proud offetchitfido has much to be proud offetchitfido has much to be proud offetchitfido has much to be proud offetchitfido has much to be proud offetchitfido has much to be proud of
 
fetchitfido's Avatar
 
Join Date: May 2006
Posts: 13,463
 

2001 SC2
Default Re: Speedometer/Odometer not working

SOHC should be compatible '91-'94. No idea where you're getting the idea that '95-'96 is what you need for a '92 but if it's a parts interchange...I wouldn't trust the paper it's written on anymore...lol

DOHC cluster's also got an oil pressure gauge for '91-'92, was removed in '93. The clusters are still plug & play swappable, but the oil pressure sender has to be swapped for a proper sensor and the extra wire run to the cluster.

REWARD EXCELLENCE!

Add to fetchitfido's Reputation
Rate the quality of this post and help fetchitfido reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fetchitfido is offline   Reply With Quote
Old 10-24-2017, 06:02 PM   #5
jswingchun
Member
jswingchun is on a distinguished road
 
jswingchun's Avatar
 
Join Date: Sep 2005
Location: Center Point, Iowa
Posts: 199
 

1992 SL2
Default Re: Speedometer/Odometer not working

After that quick interlude...

In case anyone is interested in this thread later, I pulled my cluster and cleaned the pins on the connector and the traces where it connects to the cluster. Put it back together and now everything works again.

...
92 SL2 - 280k miles

REWARD EXCELLENCE!

Add to jswingchun's Reputation
Rate the quality of this post and help jswingchun reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jswingchun is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
93 SL1 Speedometer/odometer not working teamsl1 S-Series Tech 5 12-06-2007 08:56 PM
Speedometer/Odometer Not Working Tom64 S-Series Tech 12 11-27-2007 05:30 PM
Speedometer and odometer not working?! CBXweb S-Series Tech 1 11-11-2006 10:50 PM
Odometer/speedometer not working...VSS or fuse or something else? Hanshananigan S-Series General 3 07-26-2006 11:13 AM
speedometer working, odometer not? bryan_johnson S-Series Tech 3 05-15-2003 07:57 AM


All times are GMT -5. The time now is 08:00 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.